Errors on QR Shipping Label Download
Resolved
Partial outage

All shipping labels should now work

Wed, Sep 18, 2024, 07:18 PM
4 months ago
Affected components
App
Updates

Resolved

All shipping labels should now work

Wed, Sep 18, 2024, 07:18 PM
1 week earlier...

Monitoring

We've fixed the shipping label issue affecting some of our UK users, and everything should be back to normal now. Thanks for hanging in there!

Tue, Sep 10, 2024, 02:04 PM
22h earlier...

Identified

We know some of our UK users are having trouble downloading their shipping labels. We're working on a fix and will update you again soon.

Mon, Sep 9, 2024, 03:28 PM