Resolved
Android logins and sign ups are now working as expected
Investigating
Some Android users are being sent to the registration page when they try logging into their active Depop account with Google. We're working on fixing it, but for now, you can log in directly using your username and password. Thanks for your patience!