Depop Payments sign-up error - Australia
Resolved·Degraded performance

The issue causing the Depop Payments sign-up pop-up to show incorrectly to users when attempting to list items has been fully resolved.

Wed, Mar 5, 2025, 03:18 PM
(4 months ago)
·
Affected components
App
Updates

Resolved

The issue causing the Depop Payments sign-up pop-up to show incorrectly to users when attempting to list items has been fully resolved.

Wed, Mar 5, 2025, 03:18 PM

Monitoring

We're aware of an issue where the Depop Payments sign-up pop-up is showing incorrectly to users when attempting to list items.

Our team is actively working on a fix, which will be 100% rolled out in our next app release on Wednesday. In the meantime, you can either sign up to Depop Payments to continue listing through the app, or if you'd prefer to continue using PayPal, please use Depop on the web to list items as usual.

We appreciate your patience and will provide further updates if anything changes.

Mon, Mar 3, 2025, 10:45 AM(2 days earlier)

Identified

We're aware of an issue where the Depop Payments sign-up pop-up is showing incorrectly to users when attempting to list items.

Our team is actively working on a fix, which will be 100% rolled out in our next app release on Wednesday. In the meantime, you can either sign up to Depop Payments to continue listing through the app, or if you'd prefer to continue using PayPal, please use Depop on the web to list items as usual.

We appreciate your patience and will provide further updates if anything changes.

Fri, Feb 28, 2025, 04:43 PM(2 days earlier)

Investigating

We're aware of an issue where the Depop Payments sign-up pop-up is showing incorrectly to users when attempting to list items.

Our team is actively working on a fix, which will be 100% rolled out in our next app release on Wednesday. In the meantime, you can either sign up to Depop Payments to continue listing through the app, or if you'd prefer to continue using PayPal, please use Depop on the web to list items as usual.

We appreciate your patience and will provide further updates if anything changes.

Fri, Feb 28, 2025, 04:43 PM