Selling Hub inaccessible for some users
Resolved·Partial outage

Normal service has now resumed!

Tue, Sep 2, 2025, 10:34 AM
(1 hour ago)
·
Affected components
Website
Updates

Resolved

Normal service has now resumed!

Tue, Sep 2, 2025, 10:34 AM

Monitoring

We've deployed a fix and believe we've fixed the issue. Do reach out to Support if any assistance is still needed

Mon, Sep 1, 2025, 09:52 PM(12 hours earlier)

Identified

We've identified an issue with the Selling Hub for users with offers. We're currently deploying a fix that should resolve this

Mon, Sep 1, 2025, 08:48 PM(1 hour earlier)