Depop is experiencing errors
Monitoring·Degraded performance

The Depop app and website should now be operating normally, you can log in, list, search, and check out as usual.

However, due to ongoing third-party instability, you may still experience occasional intermittent issues.

Our teams are actively monitoring the situation and will provide further updates if anything changes.

Thank you for your patience and understanding.

Mon, Oct 20, 2025, 04:53 PM
(6 hours ago)
·
Affected components
Website
App
Updates

Monitoring

The Depop app and website should now be operating normally, you can log in, list, search, and check out as usual.

However, due to ongoing third-party instability, you may still experience occasional intermittent issues.

Our teams are actively monitoring the situation and will provide further updates if anything changes.

Thank you for your patience and understanding.

Mon, Oct 20, 2025, 04:53 PM

Monitoring

Update: Service has recovered. You should be able to log in, list, search, and check out as normal.
We’re still seeing occasional delays and some missing images for items listed earlier today during the outage, these should resolve as backlogs clear.
We’re monitoring closely and will share any further updates. Thanks for your patience.

Mon, Oct 20, 2025, 10:57 AM(5 hours earlier)

Identified

Depop is currently experiencing errors due to an ongoing incident with our hosting provider. We’re monitoring the situation and will update as soon as service is restored.

Mon, Oct 20, 2025, 08:18 AM(2 hours earlier)