Resolved
All Depop services are up and running again. Sorry for the inconvenience, and thanks for hanging in there with us.
Monitoring
The fix from our 3rd party is rolling out, and services are getting back to normal. We'll update again when it has completed
Monitoring
We are aware of the issue and ask that customers are patient whilst we wait for a fix from our 3rd party to rollout. We'll update you again soon.
Investigating
We're looking into some service issues - hang tight while we figure out what's going on as quickly as we can