Depop

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
The app and website are experiencing issues
Monitoring

We've resolved the issue and the site and app are working again.

Fri, Mar 13, 2026, 03:44 PM
(5 days ago)
·
Affected components

No components marked as affected

Updates

Monitoring

We've resolved the issue and the site and app are working again.

Fri, Mar 13, 2026, 03:44 PM

Investigating

Depop users are seeing errors when using the website and/or the app

Fri, Mar 13, 2026, 03:15 PM(29 minutes earlier)