We are aware that some orders shipped with USPS prior to 25 March 2026 may display missing or incorrect tracking information on the USPS portal.
Tracking status within the Depop app remains accurate
Auto-cancellation is not affected and continue to operate as expected.
Payouts are not affected and continue to operate as expected.
In collaboration with our third-party shipping providers, we have implemented a fix, and this issue should not affect orders shipped from 26 March onwards.
We apologise for any inconvenience or concern this may have caused and appreciate your patience.
No components marked as affected
Monitoring
We are aware that some orders shipped with USPS prior to 25 March 2026 may display missing or incorrect tracking information on the USPS portal.
Tracking status within the Depop app remains accurate
Auto-cancellation is not affected and continue to operate as expected.
Payouts are not affected and continue to operate as expected.
In collaboration with our third-party shipping providers, we have implemented a fix, and this issue should not affect orders shipped from 26 March onwards.
We apologise for any inconvenience or concern this may have caused and appreciate your patience.
Resolved
This issue has now been resolved.
Purchases since Wednesday are showing accurate tracking information on the USPS website. Some purchases prior to this may still display outdated information on the USPS site; however, tracking status within the Depop app remains accurate.
Auto-cancellation and payout on delivery continue to operate as expected.
Thank you for your patience.
Investigating
USPS is currently experiencing an issue where their tracking portal may display incorrect or outdated tracking information.
This issue is limited to the USPS portal. Tracking information within the Depop app remains accurate, and packages are progressing as expected.
Auto cancellation and payouts are not affected.
We are working closely with our third-party shipping providers to investigate this further and will share updates as more information becomes available.
Investigating
We are aware of an issue affecting USPS tracking, where some orders may display incorrect or inconsistent status updates.
Our team is actively investigating and working to resolve this as quickly as possible. We appreciate your patience and will share further updates as soon as they are available.