We identified the root cause of an issue where some sellers were not getting paid out in the correct time frame after their item had been delivered. A fix has been deployed — if you are affected, please contact our support team for assistance.
Monitoring
We identified the root cause of an issue where some sellers were not getting paid out in the correct time frame after their item had been delivered. A fix has been deployed — if you are affected, please contact our support team for assistance.
Investigating
We are aware of an issue where some sellers are not getting paid out in the correct time frame after their item has been delivered. Our team is actively investigating and working on a fix — if you are affected, please contact our support team for assistance.